0

I have a site, let's call it resources.mycompany.ca - and I just set up staging for it at resources-staging.mycompany.ca .

The staging site works fine if I try to visit any specific URL (i.e. resources-staging.mycompany.ca/something). But if I try to visit the top-level URL, resources-staging.mycompany.ca/ , I'm taken to the homepage of a completely different site-in-progress, staging.mycompany.ca .

I've checked the "Site Address" and "WordPress Address" settings and they're correct, they both say "resources-staging.company.ca". I've looked at .htaccess, nothing funny there. I've checked Permalinks and re-saved. There's no redirects of any sort set up anywhere.

My only thought is that my use of "staging" preceded by a dash violated some WordPress or hosting rule... or caused it to be interpreted as just "staging", not "resources-staging" (which is essentially what's happening!). But to test this would be non-trivial (setting up a different subdomain, which is done by our IT company) so I thought I'd ask here first.

Thanks to anyone who can suggest anything!

2
  • Check your wp-config.php file for WP_SITEURL and/or WP_HOME being defined; these will override the content of your database if they're present.
    – Pat J
    Feb 1 at 17:39
  • Thanks for the suggestion, @Pat J! But alas, there's no reference to either of those in the config file. :( Feb 1 at 18:30

1 Answer 1

0

Well, like many things it was just a matter of playing the waiting game. The main URL now works fine. Just needed to wait a few days, I guess!

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 8 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.