I am just starting a website and have found my way to creating a custom page and have published it and set it as the homepage using Settings > reading so that the name of the page shows under "Your homepage displays" . Assuming "displays" is a verb, not a noun, this page should now appear when I (or anyone authorised) goes to the website, no? But it doesn't. Instead you get the following: (BTW: I have chosen Twenty Twenty-Four as my theme and it says it is active.) What can the problem be? this is driving me slightly crazy!

Thanks for any help

PS is there a distinction between the terms "Home Page" and "Front Page"?

enter image description here

  • 2
    This would be better suited a a question on the WordPress.org support forums (or WordPress.com, which it looks like you might be using), as it's not really development related. That being said, Twenty Twenty Four doesn't come with a Front Page specific template, so it should look like a normal page. Judging by your screenshot though it looks like you might've accidentally created an empty front page template? In Appearance > Editor check if you have a Front Page template and whether it has content. Commented Jan 24 at 12:40
  • Home page is technically the 'blog feed' page because WP was originally a blogging platform so that designation is supposed to be for the first page of the post feed that displays the newest posts. Traditionally this WAS always the front page of your WP site. Front Page is a secondary designation in case you don't want your blog feed to be the front page of your site and instead want it to be a static page. (Thats' my understanding at least.) Commented Jan 24 at 16:01

1 Answer 1


It sounds like you've taken the correct steps to set a custom page as your homepage in WordPress, but you're encountering an issue where the expected page isn't displaying. Let's troubleshoot this:

Check Cache and Plugins: If you're using caching plugins (like WP Rocket), clear your cache. Sometimes, caching plugins can show an outdated version of your site. Also, disable any plugins that might interfere with your homepage display (especially those related to redirection or SEO) and check if the issue persists.

Theme Customization: Verify that your theme, Twenty Twenty-Four, doesn't have any theme-specific settings that might override your Reading settings. Some themes have their own settings for the homepage display.

Permalinks: Go to Settings > Permalinks and simply click "Save Changes" without altering anything. This action can sometimes resolve unseen issues by refreshing the WordPress permalink structure.

Check Page Visibility: Ensure that the page you've set as your homepage is published and not in draft or private mode.

Inspect for Errors: Check for any PHP errors that might be interfering. Since you're familiar with WordPress development, you can enable WP_DEBUG in your wp-config.php file to see if any PHP errors are being generated.

WordPress and Theme Update: Make sure WordPress and your theme are updated to their latest versions. Compatibility issues can sometimes cause such problems.

Regarding your question about "Home Page" and "Front Page":

Home Page: This is the main landing page of a website. It's the first page visitors see when they enter your domain name in a browser.

Front Page: In WordPress, "Front Page" specifically refers to the page you set as the primary landing page in Settings > Reading.

In many cases, "Home Page" and "Front Page" are used interchangeably. However, in some WordPress setups, especially those with a static front page and a separate posts page, the distinction becomes significant. The "Front Page" is the static page you designate, while the "Home Page" could be referring to the main blog posts page if you have a different page set for your posts.

If these steps don't resolve your issue, you might consider checking the settings in the Customizer and ensuring that no page template conflicts are occurring, especially since you're using a specific theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.