0

This is the 2nd time this has happened in the past few weeks so I thought I would try and get some ideas on how to overcome. There are a few others in the localwp community that have had the same issue but their question has gone unanswered for over a year so looks like localwp aren't addressing it as an issue.

I imported a site from live into my localwp. When I try to login to the backend (using one-click login) I get a permission error and no access. When on the frontend, the wp-admin toolbar has no options except profile link.

I have compared the live database with my localwp database and the wp_users table is identical as is the wp_usermeta for all rows where user_id=1.

The user has administrative permissions but I cant login. I googled the wp administrative details and every help guide mirrored my user settings. I ended up following a guide to create a new admin user and it worked - I could login BUT, in the DB (wp_user & wp_usermeta) the data was identical - one could login and one couldn't.

What other factors am I not considering that may restrict admin permissions?

1 Answer 1

0

I suspect, this issue is much more related to htaccess rather than WordPress installation. In a standard WP installation, you can find the .htaccess file in the root directory of your WP install. This file is used for various server settings and specifically, URL rewrites. The reason for this file starts with a dot, the file is hidden, so may you need to enable the view hidden files.

Your main site might have a specific configuration that needs to be removed in the local environment. So, try testing your site both with and without the access control. And then test it again with the WordPress default htacess config.

3
  • Thanks for replying. The error shown is a wordpress generated error so I'm not sure how htaccess could be involved however, next import, I'm going to remove the htaccess to test. Oct 27, 2023 at 7:19
  • Looks I misunderstood the situation. What does the actual message say? Have you tried with wp_debug enabled?
    – Baljka Gan
    Oct 27, 2023 at 8:32
  • Error: Sorry, you are not allowed to access this page. imgur.com/a/nbhkosf Oct 29, 2023 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.