0

I tried to install a wordpress 6.3 site with php 8.1 which is standard in ubuntu 22.04. I could install it but was unable to install or delete plugins.

Always got errors about not possible headers modified.

Can anyone confirm that wordpress 6.3 runs with php 8.1

This is what I got after fresh installation.

enter image description here

Here the errors I get in google chrome.

enter image description here

Here the apache log

AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function send_origin_headers() in /_www/test.1w.at/wp-admin/admin-ajax.php:25\nStack trace:\n#0 {main}\n  thrown in /_www/test.1w.at/wp-admin/admin-ajax.php on line 25', referer: https://test.1w.at/wp-admin/

AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Error: Call to a member function main() on null in /_www/test.1w.at/wp-includes/functions.php:1335\nStack trace:\n#0 /_www/test.1w.at/wp-blog-header.php(16): wp()\n#1 /_www/test.1w.at/index.php(17): require('...')\n#2 {main}\n  thrown in /_www/test.1w.at/wp-includes/functions.php on line 1335'

AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught TypeError: mysqli_get_server_info(): Argument #1 ($mysql) must be of type mysqli, null given in /_www/test.1w.at/wp-includes/class-wpdb.php:4165\nStack trace:\n#0 /_www/test.1w.at/wp-includes/class-wpdb.php(4165): mysqli_get_server_info()\n#1 /_www/test.1w.at/wp-includes/class-wpdb.php(4153): wpdb->db_server_info()\n#2 /_www/test.1w.at/wp-includes/class-wpdb.php(4072): wpdb->db_version()\n#3 /_www/test.1w.at/wp-admin/setup-config.php(395): wpdb->has_cap()\n#4 {main}\n  thrown in /_www/test.1w.at/wp-includes/class-wpdb.php on line 4165', referer: https://test.1w.at/wp-admin/setup-config.php?step=1&language=de_DE_formal
12
  • 1
    6.3 should run on 8.1 fine? I was certainly running the early 6.3 alphas on php 8.1 fine (but then upgraded to 8.2).
    – Rup
    Aug 18, 2023 at 14:32
  • 1
    The Headers already modified error indicates that something—a theme, a plugin, or WP Core—has sent data to the browser before PHP is trying to set a header. Often this is due to whitespace after a closing PHP tag ?>. Are you using one of WordPress's default themes (ie, twenty____)? Did you start to see the error after activating a plugin?
    – Pat J
    Aug 18, 2023 at 15:20
  • 2
    Can you add the exact and complete error messages that you got, including file paths, stack traces, etc? It's difficult to give any useful info without more details.
    – Ian Dunn
    Aug 18, 2023 at 16:05
  • Just installed it again and updated my previous post. Aug 19, 2023 at 20:08
  • 1
    No plugins, original 2023 theme, and fresh install from wget wordpress.org/latest.tar.gz and gtar -xzvf latest.tar.gz on Ubuntu 22.04.3 with PHP 8.1.22 (cli) (built: Aug 14 2023 05:32:33). If I switch to php 7.4 everything runs smootly. Aug 25, 2023 at 13:26

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.