I've just bought a WordPress theme called Vehica. After installing it and its plugins I go to my website and click for example 'about us' or anything else it will redirect me to:

Not Found
The requested URL was not found on this server.

If I want to edit the layout in settings and I click preview or the edit button it gives me the same error. It can be edited with Elementor but elementor doesn't work too.

I've reached out to them and said what issues I'm encountering and this is their response:


Thank you for your email. If the error does not exist on our official demo, it is almost always related to additional plugins that have been installed or server cache issues. We encourage you to refer to this easy-to-follow article, which provides more information and solutions to common issues: 
Most common WordPress problems - debugging problems with your website - (redirects to) -> https://support.listivotheme.com/support/solutions/articles/101000380617

If you still encounter the problem after following the advice in the article, please provide:
1) Your WordPress website link, admin login, and password
2) FTP or SFTP URL, login, and password

We require both types of access because some solutions may involve server modifications, which can only be done in this manner. Additionally, certain changes cannot be made via the WordPress Admin dashboard or File Manager, necessitating FTP or SFTP access.

Please do not hesitate to contact us. We are here to help. 


If nobody'll know how to fix this then I will go back to them but I don't know if I can trust them because I would have to give them my private key and other details.

If you need any screenshots or more info just tell me I'll send them.

edit: Here is the link for my website since its not finished and I haven't settled on a domain yet, its just an ip:

It may not load for you because I'm using AWS ec2 free tier for now and it sometimes crashes (like once per week) and I have to reboot the instance.

(I'm new so I don't know if I put the right tags for this question if not I'm sorry in advance)

  • 2
    have you tried re-saving your permalinks/flushing them? What changed recently before this started happening? Note that you can't ask questions about 3rd party themes and products here, that's offtopic and not in this stacks scope, even if their support are unhelpful, or even if the theme was abandoned. Stack Overflow might be a better place to ask but given it's a premium theme people would probably need to spend money to purchase it to answer your question
    – Tom J Nowell
    Jul 7 at 14:19
  • 2
    First diagnosing step is to flush your permalinks: wordpress.org/documentation/article/settings-permalinks-screen.
    – Caleb
    Jul 7 at 14:49
  • I've just did that and one thing popped up in the sites health tab: The REST API encountered an unexpected result. Jul 8 at 21:11


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.