0

I changed our company domain name and now all i get is a 404 error.

I have updated the option table in phpmyadmin as well as updated apache2 conf.

Where else do I need to change the info for this to work?

<VirtualHost *:80>
    ServerName newdomainname.com
    ServerAlias www.newdomainname.com
    Redirect / https://newdomainname.com/


</VirtualHost>


<VirtualHost *:443>

ServerAdmin [email protected]
ServerName newdomainname.com/

DocumentRoot /var/www/testIVMC/
SSLEngine on
SSLCertificateFile /cloudflare/ivmcMaster.pem
SSLCertificateKeyFile /cloudflare/ivmcMaster.key

ErrorLog ${APACHE_LOG_DIR}/vik.com_error.log
CustomLog ${APACHE_LOG_DIR}/vik.com_access.log combined

<Directory /var/www/testIVMC/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
        Allow from all
</Directory>

    <FilesMatch \.php$>
        SetHandler "proxy:unix:/run/php/php8.2-fpm.sock|fcgi://127.0.0.1:9000"
    </FilesMatch>
</VirtualHost>

Folder structure

var-> www-> testIVMC

1 Answer 1

0

You might have already done this, but while logged into the admin of your site, go to Settings > General and then review the urls in WordPress Address (URL) and Site Address (URL). If they do not read with the new domain name, then they need to be updated.

Once you have the correct urls in place, visit Settings > Permalinks and refresh them. Usually do that by making a change, saving, then changing it back. and saving again. You can also do this via command line with WP CLI if available. Usually if a site is going to a 404, this is the go-to solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.