This WordPress site is being hosted by BlueHost (with cPanel). It is running on WP version: 6.2.2, and PHP Version ea-php74.

According the the WP's media 'add new' page, the Maximum upload file size is: 1 GB. But I can't upload a .MP4 file greater than 100MB. (ie: I can upload a 99MB .MP4 file, but not a 102MB [or greater] .mp4 file). I have tried various different .MP4 files ranging from 102MB to 300MB, and none on them can successfully upload.

When I try, I get this error:

Unexpected response from the server. The file may have been uploaded successfully. Check in the Media Library or reload the page.

The files definitely haven't been uploaded, verified by looking online via FTP.

I've contacted Tech-Support at BlueHost, but they can't figure out what the problem is on their side.

When I look at their cPanel's MultiPHP INI Editor, here are the values:

max_execution_time: 1000sec; 
max_input_time:     1000sec; 
max_input_vars:     3000; 
memory_limit:       1G; 
post_max_size:      1G;  
session.gc_maxlifetime: 1440sec; 
upload_max_filesize:    1G; 

So everything looks like it should work.

Is there some other WP or Plugin or PHP or Server setting I should be looking at that might have the 100MB limit that overrides everything else? The only error_log file I can find online is at the root level, and doesn't have anything to do with uploads (only has sitemap error log entries from 2022).

Hopefully someone has run into this problem before.. maybe specific to the BlueHost servers, that can give me some guidance on solving this issue.


In case it helps, here are the Details for server and WP settings:

### wp-core ###

version: 6.2.2
https_status: true
multisite: false

### wp-sizes ###

wordpress_size: 4.68 GB (5024256365 bytes)
uploads_size: 339.83 MB (356334597 bytes)
themes_size: 261.56 MB (274268973 bytes)
plugins_size: 140.80 MB (147636643 bytes)
database_size: 40.94 MB (42924825 bytes)
total_size: 5.44 GB (5845421403 bytes)

### wp-mu-plugins (1) ###

SSO: version: 0.4, author: Garth Mortensen, Mike Hansen

### wp-plugins-active (40) ###

Advanced Custom Fields: version: 6.1.6
Advanced Editor Tools: version: 5.9.0
Age Gate: version: 3.2.0
Antispam Bee: version: 2.11.3
Black Studio TinyMCE Widget: version: 2.7.2
Bootstrap Shortcodes: version: 3.4.0
Category Order and Taxonomy Terms Order: version: 1.7.5
Category Sticky Post: version: 2.10.1
Classic Widgets: version: 0.3
Complete Image Sitemap: version: 1.1.1
CPT Bootstrap Carousel: version: 1.12
Custom Post Type UI: version: 1.13.5
Duplicate Widgets: version: 1.2
Enable Media Replace: version: 4.1.2
Featured Images in RSS for Mailchimp & More: version: 1.6.1
Font Awesome: version: 4.3.2
GA Google Analytics: version: 20230306
Google Analytics for WordPress by MonsterInsights: version: 8.14.1d
Image Widget: version: 4.4.8
MaxButtons: version: 9.5.3
MC4WP: Mailchimp for WordPress: version: 4.9.4
Ninja Forms: version: 3.6.24
Page-list: version: 5.6
PHP Code Widget: version: 2.4
Really Simple SSL: version: 7.0.2
Recent Posts Widget Extended: version: 2.0.2
Redirection: version: 5.3.10
Simple Yearly Archive: version: 2.1.9
Smart Slider 3 Pro: version:
Spacer: version: 3.0.7
Styles For WP Pagenavi Addon: version: 1.2.1
TablePress: version: 2.1.3
UpdraftPlus - Backup/Restore: version: 1.23.4
URL Shortener by MyThemeShop: version: 1.0.17
User Role Editor: version: 4.63.3
WP-PageNavi: version: 2.94.1
WPFront Scroll Top: version:
XML Sitemap Generator for Google: version: 4.1.11
Yoast Duplicate Post: version: 4.5
Yoast SEO: version: 20.8

### wp-media ###

image_editor: WP_Image_Editor_Imagick
imagick_module_version: 1690
imagemagick_version: ImageMagick 6.9.10-68 Q16 x86_64 2021-10-14 https://imagemagick.org
imagick_version: 3.4.3
file_uploads: File uploads is turned off
post_max_size: 1G
upload_max_filesize: 1G
max_effective_size: 1 GB
max_file_uploads: 20
    imagick::RESOURCETYPE_AREA: 85 GB
    imagick::RESOURCETYPE_DISK: 9223372036854775807
    imagick::RESOURCETYPE_FILE: 12288
    imagick::RESOURCETYPE_MAP: 48 MB
    imagick::RESOURCETYPE_TIME: 300

### wp-server ###

server_architecture: Linux 4.19.150-76.ELK.el7.x86_64 x86_64
httpd_software: Apache
php_version: 7.4.33 64bit
php_sapi: litespeed
max_input_variables: 3000
time_limit: 1000
memory_limit: 1G
max_input_time: 1000
upload_max_filesize: 1G
php_post_max_size: 1G
curl_version: 8.0.1 OpenSSL/1.1.1t
suhosin: false
imagick_availability: true
pretty_permalinks: true
htaccess_extra_rules: true

### wp-database ###

extension: mysqli
server_version: 5.7.23-23
client_version: mysqlnd 7.4.33
max_allowed_packet: 268435456
max_connections: 150

### wp-constants ###

WP_DEBUG: false
WP_CACHE: false
COMPRESS_CSS: undefined
DB_COLLATE: undefined

### wp-filesystem ###

wordpress: writable
wp-content: writable
uploads: writable
plugins: writable
themes: writable
mu-plugins: writable

1 Answer 1


If you are using cPanel this may be triggered by a ModSecurity rule that block uploaded files higher than the predefined limit they use.

This is a very tricky error to spot since it's only logged serverwise. Within this log: /usr/local/apache/logs/error_log

Here is a cPanel tutorial which explains why it happens and how to override the limit: https://support.cpanel.net/hc/en-us/articles/11596999975447--ModSecurity-Request-body-Content-Length-is-larger-than-the-configured-limit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.