0
Fatal error: Uncaught Error: Class "Twenty_Eleven_Ephemera_Widget" not found in /home/stag1ngwp/public_html/dev/artpaints/wp-includes/class-wp-widget-factory.php:62 Stack trace:
#0 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/widgets.php(115): WP_Widget_Factory->register()
#1 /home/stag1ngwp/public_html/dev/artpaints/wp-content/themes/artpaints/functions.php(389): register_widget()
#2 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/class-wp-hook.php(308): twentyeleven_widgets_init()
#3 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
#4 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/plugin.php(517): WP_Hook->do_action()
#5 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/widgets.php(1854): do_action()
#6 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/class-wp-hook.php(308): wp_widgets_init()
#7 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
#8 /home/stag1ngwp/public_html/dev/artpaints/wp-includes/plugin.php(517): WP_Hook->do_action()
#9 /home/stag1ngwp/public_html/dev/artpaints/wp-settings.php(623): do_action()
#10 /home/stag1ngwp/public_html/dev/artpaints/wp-config.php(93): require_once('/home/stag1ngwp...')
#11 /home/stag1ngwp/public_html/dev/artpaints/wp-load.php(50): require_once('/home/stag1ngwp...')
#12 /home/stag1ngwp/public_html/dev/artpaints/wp-blog-header.php(13): require_once('/home/stag1ngwp...')
#13 /home/stag1ngwp/public_html/dev/artpaints/index.php(17): require('/home/stag1ngwp...')
#14 {main} thrown in /home/stag1ngwp/public_html/dev/artpaints/wp-includes/class-wp-widget-factory.php on line 62
7
  • First thing first would be to check if your theme or wordpress version can run on your new PHP version. Can you give us your WordPress version and PHP version? Apr 18, 2023 at 12:25
  • Php version old is 7.4 and the new one is 8.1 Apr 18, 2023 at 12:36
  • WordPress is 6.2 Apr 18, 2023 at 12:37
  • you've tagged your questions as wordpress.com hosting, is this a mistake? If you are a customer of wordpress.com you need to contact their support rather than asking here, but if you are not a customer of wordpress.com you should remove that tag
    – Tom J Nowell
    Apr 18, 2023 at 12:50
  • also you should update plugins and themes before upgrading PHP, is the twentyeleven theme up to date?
    – Tom J Nowell
    Apr 18, 2023 at 12:51

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.