0

I am facing the following issue while uploading any SVG file and sometimes face the same issue while uploading any image. "The server cannot process the image. This can happen if the server is busy or does not have enough resources to complete the task. Uploading a smaller image may help. Suggested maximum size is 2560 pixels."

The image size is just 11kb. I started facing this issue after installing the (Website Security - Standard) on Godaddy, which adds SSL and a firewall on the domain, while the hosting is on AWS. anyone can help with that?

3 Answers 3

0

Try with SVG enabling plugin, which also sanitizes SVG, which is very important, like SafeSVG. SVG's are not enabled by default in WP because of security issues, hence sanitization is important.

2
  • installed but still facing the same issue
    – Nader Amer
    Commented Mar 20, 2023 at 19:05
  • try temporarily disabling security and see if this is the cause
    – Lovor
    Commented Mar 20, 2023 at 21:30
0

Check if the server has php-xml module installed.

I fixed it by installing

sudo apt install php-xml
0

I started facing this issue after installing the (Website Security - Standard) on Godaddy

This is the important bit of information. The Web Application Firewall frequently blocks SVG uploads as a false cross site scripting detection. You'll need to whitelist your IP address in the firewall settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.