0

I have a problem with WordPress 6.1.1, I can't upload images in posts. The error message says 'The server cannot process the image. This can happen if the server is busy or does not have enough resources to complete the task. Uploading a smaller image may help. Suggested maximum size is 2560 pixels.' Additionally, when I go to wp-admin/upload.php, I get a 403 error. I've restored file and folder permissions, and regenerated the .htaccess file, but I'm not sure what else to do

2 Answers 2

0

To be able to help, some info is needed: Is this a production site, or a test one? Are there many plugins? Most wp problems come out of plugin failures or misconfig.

Having said that,

  1. Do you upload correct size of images? Remember that uploading too large images is pointless, as it increases load time and these images are scaled by the browser anyway - so they don't look well if they are too big.
  2. Do you have set proper memory allocation in wp-config.php and .htaccess files? Are both values the same (sometimes this error is because of value difference)?
  3. Do you have cache or website image processing plugins? Purge cache, disable these plugins and check if error appears.
  4. When did you start to get this error? Was it after update or a plugin installation? If so, turn off plugins one by one and check if error appears.
  5. If above doesn't work, enable debug mode in wp-config.php
0

You can increase memory limit, file upload limit, processing time, etc. https://muffingroup.com/blog/wordpress-cant-upload-images/

For me removing cookies worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.