I am trying to customise a plugin to add some functionality that is not part of the original.

To do this I have copied all the files into a new folder, and renamed all the function prefixes, changed the header of the main php file.

I have tried uploading the files straight to the server for activation but it was not picked up by WP so I zipped all the files to install them "properly" and it came up with the following output:

Unpacking the package…

Installing the plugin…

The package could not be installed. No valid plugins were found.

Plugin install failed.


Thinking that this may be a header problem I double checked my header but it all appeared to be correct, to my eyes at least.

Plugin Name: MC Investment Custom
Plugin URI: http://www.spectra-info.com/wp/plugins (Original)
Description: Customised plugin based on the MC Investment Plugin.
Version: 1.0
Author: Edited by Joshua Ward Original by Spectrain
Author URI: http://www.spectra-info.com (Original)

But alas, no success. The .zip file has the plugin file in it's 'root' directory so I am fairly confident that is not the problem.

Is there anything wrong with the plugin header that I can't see? I have tried it without the (Original) in the URI lines thinking that was what has mucked it but it appears not.

EDIT: Please stop replacing Customise with Customize. Everybody who types English who is not American, ie me, spell it the British (read: proper) way.

  • Have you tried disabling all plugin's and then try to activate? Feb 7, 2012 at 13:05
  • Yeah. When I upload it manually it doesn't appear in the plugins list as a deactivated plugin. So it isn't registering as anything to activate
    – Joshua
    Feb 7, 2012 at 19:57

1 Answer 1


Unsure of what I did but it seems to be working now. It may have something to do with the fact that I renamed the main php file to try and avoid a conflict. If I keep it the same file name it "registers".

  • what main php are you referring to?
    – Blowsie
    Mar 20, 2013 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.