y’all! How are you doing?!

I’ve been struggling with animated GIF images on my website for a while now, and I discovered the problem, but not the solution, still.

When I upload an animated GIF as a featured image for my products, Wordpress does it very well besides pointing to a renamed file, instead of the original, which is preventing animated GIFs from animating.

Let’s say, for example.

• File uploaded: animatedGIF.gif

• File url when put as featured: animatedGIF-300-x-300.gif

I noticed this when I opened the files that were not working (motionless) by clicking with the right mouse button and opening image address.

When I open the link, it sends me to this wrong image file destination, in this case: animatedGIF-300-x-300.gif which is funny, because that’s not the url address of the original file I uploaded (animatedGIF.gif).

Somehow, WordPress automatically adds this sufix of “-300-x-300” which prevents my animated GIFs from working, since that’s not the original URL of the file.

Funny thing is: I don’t have any image file resizer plugin for this to happen. I do have, though, Divi with WooCommerce installed, and both doesn’t have image resizer with them.

Some file I upload works like a charm. Others, the URL is renamed automatically, pointing to the wrong URL of the GIF, which prevents it from animating.

I’m searching for a solution everywhere, and the only thing I find is about the “Full Size” thing, but in recent WordPress versions, this isn’t even an option anymore. It doesn’t exist in any configuration of the image file, specially when uploading it.

Can someone help me with this issue?

By the way, this animateGIF.gif example is 300x300. Still, WordPress seems to “resize” it to 300x300 (!?) and rename the URL of the file by itself. So I can’t find any turn arounds.

What would fix this though, would be manually changing the url of the file, but WordPress don’t let me change it. When I go check the file URL, it’s right. But when I click and open the motionless image with the right click, it sends me to the wrong URL, so it doesn’t show as animated.

I would appreciate any help! Thank you!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.