So here's the general situation:

  • I have been developing an update for an existing website, let's call it domain name "example.com".
  • The url I have been using for development is "exampleshop.com".
  • I am hosting this project on a droplet in DigitalOcean.
  • The example and exampleshop domain names are both registered with a separate registrar

When I browse to example.com it does display the site, which leads me to think I've at least done all the DNS settings right. exampleshop.com displays a 404 error, which also makes sense.

The issues:

  • When I try to browse to example.com/wp-admin, it automatically redirects me to exampleshop.com/wp-admin.
  • Browsing to www.example.com also leads me to exampleshop.com instead, but I have set up a CNAME record for it.
  • The SSL certificate (Let's Encrypt) is invalid on example.com because it refers to exampleshop.com

What I've tried:

  • I've made sure there are no redirects or domain forwards set up on either domain.
  • I've tried using the IP leading directly to the DigitalOcean droplet and adding /wp-admin to that
  • I've tried using combination of using https versus http and using www. or not, same results.
  • I've also tried out the top answer on this old question I found (changed the site and home url directly in the database) and checked it by doing an SQL select for all those values.

I have a few years of experience with launching and hosting websites, but this is only my second wordpress project and I cannot figure out why this is happening. I gave the DNS settings over 24 hours to update, should I just wait another day and hope for the best? Is there some connection between these issues that I'm missing?
Should things be bleak, I do have a DigitalOcean backup from four days ago and I did migrate my project to a file just before transferring domain names. Should I just wipe my DigitalOcean droplet and restart from a backup?

This is a project I'm building for work where I normally don't get to build websites (which I love to do), so I'd hate to make a bad first impression by struggling with this for so long. Any help is extremely appreciated!

1 Answer 1


Problem found :) The DigitalOcean droplet was set up for the exampleshop.com domain name, so I needed to go into the apache vhost configuration and change the config files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.