0

Moved a site to a new url. The site admin can login but when trying to acess wp-admin gets a perms error. -- Sorry, you are not allowed to access this page. ---

This has to do with the wp_options table because if I just load that the error starts and if I load everything but it I don't get error...

I have moved the urls in the option table to the new domain. There doesn't seem to be much else in there that would cause this issue.

2
  • You may have missed a record somewhere in that table that's still pointing to the old URL. Did you run a search and replace or just attempt to do it manually? Nov 14, 2022 at 22:36
  • 1
    @TonyDjukic - it seems that it has something to do with renaming the prefixes...
    – STing
    Nov 15, 2022 at 2:55

1 Answer 1

0

Assuming that the two locations in the options table have your new domain URL, go into Settings, Permalinks and change the setting to something else (anything). Save it, then go back into the same screen and set it to what you want it to be.

1
  • It is because I tried duplicating the site via new url as part of the same database so I just renamed the prefix. I have done this in the past without an issue albeit... been a while. But anyway I thought I made all of the necessary changes and no bueno. Moved to different database (which was extra work) while keeping same prefix and worked just fine... If I understood what I missed I would do a write up on it.
    – STing
    Nov 22, 2022 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.