0

I accidentally changed the url of my wordpress page, which I finally managed to restore in phpmyadmin, the first page of my website works, but the second page doesn't, and I can't even log in to the admin interface because it throws this error message:

Fatal error: Uncaught ValueError: setcookie(): "path" option cannot contain ",", ";", " ", "\t", "\r", "\n", "\013", or "\014" in C:\xampp\htdocs\hh\wp-login.php:481 Stack trace: #0 C:\xampp\htdocs\hh\wp-login.php(481): setcookie('wordpress_test_...', 'WP Cookie check', 0, '/hh\r\n/', '', false) #1 {main} thrown in C:\xampp\htdocs\hh\wp-login.php on line 481 This is the part of the code: if ( SITECOOKIEPATH !== COOKIEPATH ) { setcookie( TEST_COOKIE, 'WP Cookie check', 0, SITECOOKIEPATH, COOKIE_DOMAIN, $secure ); }

I looked to see if I had hit something there, but no. I've also tried to replace it with a code copied from github, but that doesn't work either. Thank you in advance for your help!

1 Answer 1

2

The error message you see points to this part within the wp-login.php file:

setcookie( TEST_COOKIE, 'WP Cookie check', 0, SITECOOKIEPATH, COOKIE_DOMAIN, $secure );

to its "path", which is the 4th parameter:

SITECOOKIEPATH

If you check how that constant is defined, that is:

define( 'SITECOOKIEPATH', preg_replace( '|https?://[^/]+|i', '', get_option( 'siteurl' ) . '/' ) );

meaning the "siteurl" option of WordPress defines it, which would come from your admin area Settings -> General -> WordPress Address (URL). This is stored within the [prefix]_options database table, so that is where you should try to fix your url: option_name -> siteurl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.