From the command WP-Cli is unable to install or update plugins, throwing the following error:

The package could not be installed. "PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

Installing the plugin...
Warning: The package could not be installed. "The plugin contains no files."
Plugin installation failed.
Warning: The 'wordpress-seo' plugin could not be found.
Error: No plugins installed.

I get this error regardless of which plugin I try to install.

Troubleshooting that I have tried.

  1. switched to unlimited disk space
  2. verified that the php zip module was installed
  3. verified the php mempry_limit is 512M within php.ini (php8.1)
  4. directly defined php memory_limit in wp-config.php as 512M

Any clues?

  • I guess we need to know a bit of the surroundings. Like what version of WP-CLI, what OS, what folder structure, what Shell, what user you execute the commands with? To me it sounds a bit like either a permission issue or maybe php-zip missing. Maybe also simply try to update WP-CLI itself first.
    – leymannx
    Oct 16, 2022 at 10:24
  • 1
    @leymannx seems that the problem resolved itself with me doing absolutely nothing. After posting, I continued my work via GUI. 5-6 hours later, I tried the exact same commands and everything worked. My only guess is perhaps, my vbox VDI test server was running low on memory. In any case, my set up is Ubuntu 20.04 server, Virtualmin PRo, LAMP, PHP8.1. During my troubleshooting, I did change wp-cli.phar from 750 to 775 permissions and verified that the php-zip was installed...
    – mjones
    Oct 17, 2022 at 3:09


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.