0

There's no "add featured image" in the settings section in a page I created. On the other hand, a similar blogpost I created has this setting. I went over some websites which told me that I needed to enable it in screen options for it to be displayed in the settings, but that didn't work either. Please help me out (I am not coding in PHP or CSS, just using the wordpress editor to create my website).enter image description here

1 Answer 1

3

You can enable featured image for pages (and other post types) by using the line below. This goes in your functions.php file.

add_theme_support( 'post-thumbnails', array( 'post', 'page' ) );

If you're not comfortable with editing theme files then you should contact your theme developer. If featured images are not enabled by default in your theme they have to be enabled first.

3
  • Thanks for the reply! I am able to add featured images for blogposts, but not pages. Is this a problem specific to some themes or is this how it is? Also I am using the wordpress editor and not coding, so do you have a way for me to do the same without coding?
    – Rakshith
    Commented Aug 23, 2022 at 14:47
  • 2
    If you're not comfortable with editing theme files then you should contact your theme developer.
    – DeltaG
    Commented Aug 23, 2022 at 15:19
  • @Rakshith Also, in future please note that this site is intended for development and coding questions. For user support you should try the WordPress support forums, or the support channels of theme and plugin authors. Commented Aug 24, 2022 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.