0

After performing an SEO Audit on my client’s website I found out that several images have a double slash in their URLs. This seems to be happening just to media files, and the double slash is appearing this way: “/uploads//”.

Here’s an example:

https://akmicorp.com/wp-content/uploads//2018/10/heavy-duty-truck-mountain-1024×682.jpeg

How can I fix this?

Notes:

  • I have checked the wp-config.php file and the htaccess file and there is no define( lines related

  • I have checked the WordPress Media Settings and the Full URL path to files option is properly configured (https://akmicorp.com/wp-content/uploads)

Warm Regards,

Leandro

1
  • If they are that way in the HTML in post_content then it's just written that way. No setting will change it. You'll need to do a search-replace on the database to fix it. Apr 6 at 4:39

1 Answer 1

0

if you are familiar with WP-CLI ( Wordpress command-line interface ) you can very easily search and replace the wrong uploads// url with uploads/.

you will need to install the wp-cli.phar file in the root of your directory.

there are many tutorials online that explain how to install it for your relevant system. It is very straight forward if you have used other command line tools before

Wordpress.org explains the search-replace.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.