0

I've been trying to redirect users to the profile page when accessing profiles of users and self. Currently it's redirecting to activity page by default.

Eg: example.com/members/username

is showing the activity page as default.

I've tried setting the below line in wp-config.php as suggested in Buddypress forum. But doesn't seem to be working.

define('BP_DEFAULT_COMPONENT', 'profile');

Is there any workaround to implement this, instead of profile all the other links(friends, groups, notifications etc.) are working when setting in BP_DEFAULT_COMPONENT.

1
  • That definition works for me. Are you using a theme builder or youzer or some additional plugin re BuddyPress? If so, try deactivating them.
    – shanebp
    Feb 14, 2022 at 22:14

2 Answers 2

0

Are you sure you've added the constant definition in the right place? As the BuddyPress codex says:

When adding the code to wp-config.php, place it after define(‘DB_COLLATE’, ”); and before the authentication keys. If you add this line to the bottom of wp-config.php, it will not work.

1
  • Yes, I'm sure Artemy. I also tried creating a bp-custom.php there also it's not working. I'm currently facing issue when "profile" is set as BP_DEFAULT_COMPONENT. Feb 15, 2022 at 4:12
0

This got resolved when I set the Activity Streams Page to - None - in Dashboard->Settings->Buddypress->Pages.

I'm not sure what this setting has to do with the default page. Can someone explain about it?

site.com/wp-admin/admin.php?page=bp-page-settings

Pages Configuration Settings in Buddypress

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.