0

Hope someone could help me.

Link problem:

This is my Homepage URL: https://epix.com.mx
Portfolio onepage link: https://epix.com.mx/#Projects
Portfolio item link: https://epix.com.mx/?portfolio=huitzilin (permalink), once here if I want to go back to my homepage using the same menu, the link is wrong: https://epix.com.mx/?portfolio=huitzilin#Home
correct one would be: https://epix.com.mx/#Home

Why Is this happening and how can I fix it?

Thanks!

0

You should check your Appearance > Menus Select activated Menu & check its links by clicking on the name tab, you are probably using #Home link instead of using a full url of that specific page.

Example:

Home Url should be: https://epix.com.mx

You might be using: #Home

Update: If your website has more than one page/s than you should create separate navigation menus.

Separate menu for homepage & Separate menu for other page/s this way you can avoid css style conflicts. You should have an option to use separate menu for specific Page. You can use #home navigation as your homepage menu & other full link navigation for the rest of the pages.

6
  • Thanks @Arsalan, I appretiate your help. The problem is that I have a onepage website and menu links are following this format: #about #projects #testimonials #contact since it navigates in the same page. For the portfolio items WP sends me to a different link (which changes to another page) and there is when it doesn't work anymore> Righ now I changed the "About" link on the menu to epix.com.mx/About but it shows it in red since n the homepage is an active link and also doesn't work that way.
    – Epix Media
    Jan 13 at 14:13
  • i.imgur.com/ITCilRY.png
    – Epix Media
    Jan 13 at 14:18
  • Yes Obviously, coz that's the active link. Simply you need another Navigation bar for the page which has scroll sections, (like your homepage) where you can only put sections ids like #About #Contact etc & full links on another Nav bar. That's exactly what's happening in your Demo theme as well. Check to see if there are 2 or more menus created in your Menu list Jan 13 at 14:57
  • @EpixMedia i just updated my answer following your concern. Jan 13 at 15:04
  • I appreciate your help, you're absolutely right, I had the other menu disabled. Right now I enabled it and apply proper links.. now it works perfectly THANK YOU SO MUCH!
    – Epix Media
    Jan 13 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.