0

Here's what I see when I click on the HTML tab in the editor...

<div style="margin: 10px 0;"><a href="test.jpg" rel="nofollow" target="_blank">
<img style="float: left; margin: 10px; max-width: 25%;" title="test" src="test.jpg" alt="test" />
</a><a href="test" rel="nofollow" target="_blank">
<img title="PDF file" src="test.png" alt="PDF file" />
<span style="font-weight: bold; text-transform: capitalize;">Test ...</span>
</a>
<span>test <strong>test</strong> test? test, test, i.e., </span>
<a href="test.pdf" rel="nofollow" target="_blank"> ... Get Content Here</a>

</div>

And here's what I see when I look at view source in Chrome and FF:

<div style="margin: 10px 0;">
        <a href="test.jpg" target="_blank" rel="nofollow"><br />
            <img style="float: left; margin: 10px; max-width: 25%;" title="test" src="test.jpg" alt="test" /><br />
        </a></p>
<p>
            <a href="test" target="_blank" rel="nofollow"><br />
                <img title="PDF file" src="test.png" alt="PDF file" /><br />
                <span style="font-weight: bold; text-transform: capitalize;">Test &#8230;</span><br />
            </a><br />
            <span>test <strong>test</strong> test? test, test, i.e., </span><br />
            <a href="test.pdf" target="_blank" rel="nofollow"> &#8230; Get Content Here</a>
        </p>
</p></div>

Any ideas what's going on?

1

I think you're referring to all the paragraph tags, those are coming from wpautop. You can either disable it or write around it...many chose to just disable it, especially those who are particular about content display.

1

Your code is being parsed by the Apache web-server. That's why it appears different once it's viewed in your browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.