0

I am trying to automate contact form 7 submissions via curl. But I am stuck bcoz of recapcha it gives me spam status whenever I send a post request.

enter image description here

How do I disable recapcha on a specific form?

1 Answer 1

0

For particular form I don't know it's possible or not but yes you can disable that on particular page using below filter, I have used and it's working fine for me:

function contactform_dequeue_scripts() {
    if (is_singular()) {
        $post = get_post();
        if (has_shortcode($post->post_content, 'contact-form-7')) {
            wp_dequeue_script('contact-form-7');
            wp_dequeue_script('google-recaptcha');
            wp_dequeue_style('contact-form-7');
        }
    }
}
add_action('wp_enqueue_scripts', 'contactform_dequeue_scripts', 99);

Check once maybe it helps to you for resolving your issue.

1
  • it will disable style and javascript not the server-side validation Commented Dec 7, 2021 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.