5

I have a site where I display the same exact footer on every page. There is one exception, though. On one certain page I need to change one small part of the footer.

I figure the simplest way to do this is to check, within the footer, whether I'm on that page or not. It wouldn't make sense to change the whole entire footer for that page since I'm only changing a tiny part of the footer, deep within the footer.

The problem is that whenever I call $post->ID or the_id() from within the footer, it gives me an ID that clearly doesn't match the post I'm on. It always gives me 89, no matter what page I'm on in the site.

I figure I must be doing something wrong. Can anyone tell me what it is?

1
  • 1
    Are you altering the main query at all? Maybe try adding wp_reset_postdata after your query if so.
    – Shane
    Jan 20, 2012 at 16:42

5 Answers 5

16

It sounds like you are altering the global $post data somewhere (usually another loop). Be sure to call wp_reset_postdata() after you are finished with something that sets up post data in an alternate loop.

0

the_ID just echo the post , it doesn't return the ID, if you want the ID for the particular post ,

use <?php get_the_ID(); ?>

1
  • No, the_ID() echoes/displays the post's ID, while get_the_ID() returns it. Just to clarify.
    – Jared
    Jan 20, 2012 at 20:48
0

It may be more reliable to test the status of $the_wp_query, which is the main query for the active page. The value of $post is simply whatever the last loop ended with, so you may have plugins affecting the value.

0

Codex says (emphasis mine):

Displays the numeric ID of the current post. This tag must be within The Loop.

You try to use it in the footer, so failure is very well documented.

Let me suggest this: write a small plugin with its own post ID array (class member or uniquely named global; should be an array in order to deal with pages containing multiple posts).

Create a shortcode that adds the ID of the current post to this array. In the footer, you can read all IDs you need from it and you can be sure no one has tempered with them.

0

My issue was I has assigning other values to the $post. I renamed $post to something else and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.