0

Lately, my WordPress web tends to show a random page when an internal link is clicked.

It currently does not show the home page as the root page.

I can't find any system in this behavior. Sometimes, all internal links show the same page, sometimes a random page.

Even internally, when I edit a page and click preview, a different page than the one I'm editing is displayed.

Apparently, with cloudflare in developer mode, things work. So how do I make cloudflare behave?

Any and all help appreciated.

The root page is at www.grendel.no. The page that shows up now is not the actual home page. The site is self-hosted.

Thank you.

1 Answer 1

0

The problem is with the permalinks.

Swithing to «plain» made the problem go away. Still haven't solved how to get correct behavior from «post name». With this setting, wordpress just delivers a random page.

Case closed.

1
  • Can you elaborate? How was the problem solved? If someone else finds your question & answer in the future, it would be nice to guide them on how to solve the problem.
    – kero
    Commented Sep 3, 2021 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.