1

I'm not sure how but it seems Gutenberg or the block editor has been disabled. I've tried several plugins to re-enable but nothing is doing any different.

I only have 1 block showing up on pages (Classic Editor) and cannot add anymore.

I cannot find anywhere that will 'enable' the blocks again. Does anyone have any idea what's happened here and how to get it back to default behaviour?

enter image description here

1
  • Have you tried switching to "default" wordpress themes? disabling all plugins?. I would start with switching a theme, if that solved the problem then there is something in the theme. If you choose the diable plugins approach first, go one by one, not all at once, and see what plugin coused it Sep 1 at 13:40
1

Sounds like what I had to deal with recently, having forgotten I had this option checked:

enter image description here

on the user profile page.

Uncheck it if needed, otherwise it will display the post/page as:

enter image description here

with e.g. the add blocks button (+) disabled.

5
  • lol, did core actually change the styling so it will look like the block editor? or is it also a block editor but with only one block ? Sep 1 at 15:14
  • Hehe good question, I thought the site was broken or something or worse, wasted way too much time on this so I wasnt in the mood to dig further at the time☺ I wonder if a simple notice would help users out of this situation.
    – birgire
    Sep 1 at 15:44
  • 1
    looks like block editor with one block WTF. Not going to check if the post content being saved is in the "old" format requiring autop Sep 1 at 16:45
  • Yes! This! Thank you :) I feel stupid now.
    – Lee
    Sep 2 at 14:27
  • @Lee Glad it helped, you were not alone falling into this ux trap :-)
    – birgire
    Sep 2 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.