0

I have WP All Import on one website and I've realized that WP CLI doesn't load the plugin custom commands. It's not related to WP All Import though, because there should be even other plugins commands but they're missing too.

Those commands are available in my local installation.

The production installation has a different folder structure cause I use a deploy system (WP-Deploy). Basically, it is structured like this:

  • current folder where the actual release is linked to. It's the document root. Virtual host points to this folder. Inside current there are:
    • wp-content folder with themes, plugins, and uploads folders
    • wordpress folder with WordPress source files
    • wp-config.php
    • .htaccess
    • index.php

I tried:

  • setting a wp-cli.yml with the path to the WordPress folder
  • defining WP_CONTENT_DIR through dirname(FILE) instead of $_SERVER['DOCUMENT_ROOT']

None of the above worked for me.

Do you have any clue?

The stack on the server is NGINX + Apache 2 hybrid, PHP 7.4, WP CLI 2.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.