I want to setup a wordpress page on a raspberry pie in my home (running Arch Linux ARM, nginx for routing). The installation seems to have worked and I can access the wordpress app from my laptop, setup the database and admin login and get the first blog post. Problem is that none of the pages (with exception of the admin dashboard) have any css styling on them.

It doesn't matter whether I access the installer via the raspberry's local IP, its hostname, my public IP or a URL that I point to my public IP. (The arch wiki has a cryptic hint that a mashup between IP and URL could be a cause.)

The css files ought to be accessible, when I take their addresses written in the html source code, my browser can load them.

I do not have an SSL certificate. I've read that some http/https mix-up could be the cause for some, though I understand that plain http should not have that issue.

I'm at my wit's end. Maybe you can help me figure this out.


  • 1
    Are the addresses for the CSS from the HTML also pointing at the same server? I'd look in your browser's debug tools to see if there are any errors in the console there too. But I'm not aware of any cross-site restrictions for CSS. It might also be worth checking that the CSS files are served with the correct content type, text/css, which you can probably see if your browser debug tools network tab for the CSS file, and on the headers tab within that.
    – Rup
    Commented Aug 22, 2021 at 11:05
  • 1
    Have you verified that all of the WordPress files are owned by the web server owner? In looking at setting up Nginx on RPi, this is one of the steps to ensure the web server is set up properly. Also, make sure all file permissions are correct, although this appears not to be an issue.
    – ScottM
    Commented Aug 22, 2021 at 11:16
  • 1
    @Rup • The css addresses are written with the URL, yes • The Debug Console only complains about the missing favicon, which I don't think I care about at the moment • Under the Network tab, the css files are marked as "stylesheet" Commented Aug 22, 2021 at 11:19
  • 1
    @ScottM The wordpress folder belongs to the http user and group (as of arch wiki ). Though I do start nginx as root. Commented Aug 22, 2021 at 11:22

1 Answer 1


Ok, I fixed it. Apparently, I had to explicitly add mime type rules in the nginx config:

include /etc/nginx/mime.types;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.