-1

I get this message when I go to add a new Plugin. Do you know a way to solve this?

An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.enter image description here

1
  • It's worth checking your server's error log in case there's any more information there. (or your PHP error log if you have a separate log, or wp-content/debug.log if you've enabled that.)
    – Rup
    Jul 4, 2021 at 14:06

2 Answers 2

0

This could be due to several different reasons. The quickest answer is to ensure your server is running PHP 7.4+ and the cURL extension is enabled.

If the problem persists, suggest reading through the support forums to see if you can find information relative to your situation.

1
  • curl - yes, although I'd be surprised if WordPress lets you get that far without it. Why would the PHP version matter though?
    – Rup
    Jul 4, 2021 at 14:08
0

First you need to check if the plugin wp.org SVN repository is up and running:

You should be able to confirm using this url, with name of plugin at the end:

https://plugins.svn.wordpress.org/smartlink-dinamic-urls/

If there's a tag / branch folder with the plugin inside then wp.org repo is Ok.

You can then check if server configuration is fine. Go to tools >> site health >> server and check all files have write permission,

Additionally, check that server options has recommended values. | option | value | |:----- |:-| | upload_max_filesize | 16 MB or greater | | memory_limit | 128 MB or greater | | max_execution_time | 60 or greater | | max_input_vars | The minimum value is 4000 but the recommended is 6000. |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.