0

We've recently moved providers for our WordPress website and can preview the website using hosts.cx or editing our hosts file to point at the new server IP address before we change the A records for our domain to point at the new website.

However we've found that the login doesn't work... just reports that the username and password are incorrect (even though we copied the users etc from the current site intact).

Does WordPress do anything / have any sort of configuration that could cause this? We spoke to our hosting provider and they claim that it needs the DNS for the domain changing before the login will work properly but this seems a bit weird considering the rest of the site works fine and we've never had issues with other PHP or even Ruby apps when previewing them like this... so does WordPress have something in place that could cause this?

6
  • No, I can't think why that would matter. (Did you keep the same random values in wp-config? Although I don't think that's used in the password hash either.) You could ask your host to give you the technical explanation why it won't work without the DNS change but I'd guess they're making it up and won't have one.
    – Rup
    Jun 10 at 11:39
  • Well I tried the reset password as well just in case something was up... and they said emails will also not work until the domain is pointed at the server... again doesn't seem correct to me... but?
    – Cameron
    Jun 10 at 11:40
  • No, that sounds wrong too. Emails should work fine but might get flagged as spam if you use SMTP and have SPF and DKIM set up on the domain pointing to the old host's outbound SMTP servers not the new ones, but they should still get sent and should hopefully be somewhere in your inbound mail system. How are you sending email? Do you have SMTP set up correctly at the new host? Or if e.g. you're using an API like MailGun, Postmark or SES then the migration should make no difference (unless you've IP restricted the APIs)
    – Rup
    Jun 10 at 11:42
  • 1
    You could try fetching the password hashes from the user table in the database and make sure they match the old values, or that you can verify the hash with PHPPass locally.
    – Rup
    Jun 10 at 11:43
  • (I'm not sure what you mean by using hosts.cx? Changing the IP address in the hosts file should definitely work though.)
    – Rup
    Jun 10 at 11:46
1

Turns out this is a total lie from the host company (or a misunderstanding on the part of the support people) as I managed to get access to the database and manually update the password hash and then it worked fine. So seems something somewhere has been changed by them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.