0

I am using the theme colibri for my site/blog and I have set it so the comments will display at all times, logged in or not: enter image description here

The site is: https://www.miniatureartacademy.com/2021/04/20/minotauro-pt4/

Here is the comments php and I cannot see anything that I could remove.

How can you enable comments for anybody, including non-registered users?

<?php
if ( post_password_required() ):
    return;
endif;

?>

<div class="post-comments">
    <h3 class="comments-title">
        <span class="comments-number">
            <?php comments_number(
                __( 'No responses yet', 'colibri-wp' ),
                __( 'One response', 'colibri-wp' ),
                __( '% Responses', 'colibri-wp' )
            ); ?>
        </span>
    </h3>
    <ol class="comment-list">
        <?php wp_list_comments( array( 'avatar_size' => 32, ) ); ?>
    </ol>
    <?php
    if ( get_comment_pages_count() > 1 && get_option( 'page_comments' ) ):
        ?>
        <div class="navigation">
            <div class="prev-posts">
                <?php previous_comments_link( __( 'Older Comments', 'colibri-wp' ) ); ?>
            </div>
            <div class="next-posts">
                <?php next_comments_link( __( 'Newer Comments', 'colibri-wp' ) ); ?>
            </div>
        </div>
    <?php
    endif;

    if ( ! comments_open() && get_comments_number() && post_type_supports( get_post_type(), 'comments' ) ):
        ?>
        <p class="no-comments"><?php esc_html_e( 'Comments are closed.', 'colibri-wp' ); ?></p>
    <?php
    endif;
    ?>

</div>
3
  • I think they setting you need to change is the one that auto closes comments after a set number of days, the settings in your screen capture refer to permissions regarding who is permitted to comment, not who is permitted to see them. Apr 21 at 16:37
  • Thanks @TonyDjukic actually this is unchecked. So there is no limit for me on my pages. "Automatically close comments on posts older than" Apr 21 at 18:44
  • Didn't work with colibri theme, but did you try to allow comments only for registered users? (Settings - Discussion, and there goes checkbox "Users must be registered and logged in to comment")
    – anton
    Apr 22 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.