0

This problem started when I wanted to create a new post. I'm using the Elementor editor, so I created a new post, set the title and featured image and then clicked on "Edit with Elementor" as usual. While Elementor was loading, I got this error.

My first thought was that this is an Elementor issue. But then I tried to first create a new post and then save it as a draft or publish it first before editing it with Elementor, and to my surprise, nothing happened. No matter what I do, I always end up with an "auto-draft" with no content which I can't change for the life of me. Can't change the name, slug, or to be precise, I can't save any changes.

The funny thing is that this happens only for posts but not for pages. I can create new pages and edit old pages and posts without problems.

Tried deactivating plugins I installed since publishing my last post, clearing the cache, using a different browser, updating everything, but nothing worked. I'm not currently using a caching plugin and I see no errors in devtools.

Any idea what could be wrong? I saw this question where they were doing something with the REST API, but I have no idea what that is, so I can't tell if I can help myself with it.

4
  • 1
    You can try the troubleshooting steps I suggested (e.g. deactivate plugins and switch to a default theme) in my comments on the linked question and see if the issue persists.
    – Sally CJ
    Apr 1, 2021 at 13:42
  • I tried deactivating all plugins and switching to the twenty-twenty-one theme, but the issue persists. I've been thinking, the last thing I was doing was dequeuing some css files manually and replacing them with my own to optimize the website, but I tried reversing that and it didn't help either.
    – R2vale
    Apr 6, 2021 at 12:46
  • Then maybe you should hire someone to check the issue for you.. but some other things you can try, in no specific order: 1) Clear your site and browser caches. 2) Reinstall WordPress (core files). 3) Run a security scan on your site. 4) Check the .htaccess file for anything suspicious.
    – Sally CJ
    Apr 8, 2021 at 3:49
  • Thanks @SallyCJ. I tried clearing caches and I checked htaccess file, all seems fine. When running a few different security scans, the only error I get is "could not find the wp-content directory". However the wp-content directory is where it has always been. Could this be a permissions thing?
    – R2vale
    Apr 9, 2021 at 7:28

1 Answer 1

0

Finally found a solution to my problem.

In my case I had set a 301 redirect for my front page (that is for "domain.com") to another page I wanted to use as the front page. Apparently that caused a problem when Elementor tried accessing it's content (although I'm not sure why it needs the content of my front page if I'm creating a new post).

So I removed the 301 redirect and just changed which page is set as the front page in Wordpress.

To clearify: I was avoiding the front page setting because I was afraid what was going to happen to all my backlinks pointing to the page I was redirecting to. But when you change your front page in Wordpress, the page's URL becomes "domain.com" and it's previous url "domain.com/page" is automatically 301 redirected to "domain.com". Which means that all links are kept unharmed.


Edit: I finally got rid of the problem. As it turns out, my redirect was only a part of the problem concerning only Elementor. But the ability to save/publish posts in Wordpress turned out to be an internal Wordpress error. After a few weeks of dealing with this issue I finally got an error when clicking on 'Publish' inside Wordpress, saying: "The response is not a valid JSON response".

After browsing around a while I found out that I was far from being alone in this issue. It turns out it is connected to permalinks, I found that this article explains it best.

I was able to fix the issue by either changing the permalink structure to 'plain' or by installing the Classic Editor plugin. Since plain permalinks are not acceptable for me, I chose the second. I'm sure this could also be resolved in a more elegant way, but I'm not proficient enough with backend development to do it. Hopefully this will be resolved with future Wordpress updates.

2
  • I'm glad you found the solution, but how did you set the 301 redirect? Perhaps adding the details would be helpful to others who might be having the same or a similar problem.
    – Sally CJ
    Apr 9, 2021 at 12:59
  • Actually, I spoke to soon. Removing the 301 redirect did help me to access a new post with the Elementor editor, which I san use normally now. But if I want to publish any changes in Wordpress directly (like set a featured image), no changes are saved. My redirect looked like this: RewriteRule ^/?$ https://domain.com/page/ [R=301,L]
    – R2vale
    Apr 9, 2021 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.