2

I have to get following error on the localhost

"code":"application_passwords_disabled"

enter image description here

  • Server & Apache: Xampp v3.2.4
  • OP: Win 10 64Bit
  • WP: v5.6.1

1 Answer 1

13

That error could happen if wp_is_application_passwords_available() returns a false, and the docs says:

By default, Application Passwords is available to all sites using SSL or to local environments. Use ‘wp_is_application_passwords_available’ to adjust its availability.

So, to enable the Application Passwords:

  • Enable SSL on your localhost,

  • Or define WP_ENVIRONMENT_TYPE either as a global system variable or constant, and set its value to local:

    // Example when defining it as a constant.
    define( 'WP_ENVIRONMENT_TYPE', 'local' );
    
  • Or use the wp_is_application_passwords_available hook like so:

    add_filter( 'wp_is_application_passwords_available', '__return_true' );
    
4
  • 1
    Hey, Sally! It took 10 days, but at last, I managed to do what I was going to when we last had a chat. And the system didn't filter it this time. So now I can fully express my thanks for your help!
    – Arsen K.
    Mar 4 at 5:54
  • Well, thanks a million, @ArsenK.! (but I hoped this and the others have helped or would truly help you 😉)
    – Sally CJ
    Mar 4 at 15:06
  • 1
    They did help! I've learned a lot from your answers. And I was impressed that most of them are really comprehensive. I must say - you are a true WP monster! :)
    – Arsen K.
    Mar 5 at 18:27
  • 1
    Thanks again @ArsenK.! I'm glad my answers helped you :)
    – Sally CJ
    Mar 6 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.