1

I have to get following error on the localhost

"code":"application_passwords_disabled"

enter image description here

  • Server & Apache: Xampp v3.2.4
  • OP: Win 10 64Bit
  • WP: v5.6.1

1 Answer 1

7

That error could happen if wp_is_application_passwords_available() returns a false, and the docs says:

By default, Application Passwords is available to all sites using SSL or to local environments. Use ‘wp_is_application_passwords_available’ to adjust its availability.

So, to enable the Application Passwords:

  • Enable SSL on your localhost,

  • Or define WP_ENVIRONMENT_TYPE either as a global system variable or constant, and set its value to local:

    // Example when defining it as a constant.
    define( 'WP_ENVIRONMENT_TYPE', 'local' );
    
  • Or use the wp_is_application_passwords_available hook like so:

    add_filter( 'wp_is_application_passwords_available', '__return_true' );
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.