0

I can't find a single answer to get me past this, so I changed the email address in wordpress, but while doing so, I was trying to add 2 emails with a ',' in between, but I made a type, and entered

email1@domain.co.ukemaildomain.co.uk

A complete mess of two emails, however now I can not change it at all, if I reset, we confirm the new admin, nothing, if I go into myphpadmin and change it in options, it won't change, nothing I do will change it's email (how can myphpadmin not overwrite this)

Also what If I delete it in myphpadmin, what would happen??

3
  • personally, I can change my own in options via phpmyadmin. but, if you can't, try export it first, and edit .sql file with notepad or other text editors. and then delete the options table in phpmyadmin, and import the edited one. – Tiyo Feb 8 at 15:24
  • If PHPMyAdmin cannot change the value of that row then this is not a WordPress problem. Please confirm that the SQL user you are using has the necessary privileges to write to that table, what you describe is not normal behaviour – Tom J Nowell Feb 8 at 15:59
  • You need to speak with your hosting provider if direct SQL queries cannot change the row in the database. Nothing on the WP side can fix that – Tom J Nowell Feb 9 at 10:50
1

You can't have more than one admin email, if you need it to arrive in more than one inbox then you need to do that at the other end, via a mailing list or forwarding rules, etc

I don't know how you set the admin email to an invalid email address with commas, but, you can fix this by setting the option directly to the email you want. As you have PHPMyAdmin you can do this directly in the options table

For example, I changed the admin_email option from test@test.test to test@test.test3:

enter image description here

Now the admin email address is test@test.test3. Notice it has a pending change to test@test.test, this is because new_admin_email was not changed. Deleting the new_admin_email option will fix this, as will clicking cancel.

6
  • "if I go into myphpadmin and change it in options, it won't change" – user3593556 Feb 8 at 15:46
  • if you cannot change the value of the row in the database with an SQL client directly, e.g. PHPMyAdmin then this is not a WordPress problem. PHPMyAdmin does not use or load WordPress. Are you sure that it did not change is what you meant to say? Do you mean the SQL query to change it failed with an error? Do you mean that changing it in the database does not update WP Admin? – Tom J Nowell Feb 8 at 15:57
  • Yeh I change it to the correct one in myphpadmin, it sits there happy, but if I refresh the page it shows the old email again, I can't understand how you can't overwrite content in the database, whats could be preventing it from saving – user3593556 Feb 8 at 16:35
  • the PHPMyAdmin page, or the WP Admin page? Are you sure that you're not changing the value in the browser but not saving/applying the change? There should be a box that shows up saying 1 row affected, and there's the edit link, if you use the page that loads, it shows you the SQL query it ran as well as how many rows were changed. If PHPMyAdmin could not change it then you would not see those things, you would see errors – Tom J Nowell Feb 8 at 16:54
  • Yep shows that it's worked and changed one row link but if you refresh the page the old wrong email reappears – user3593556 Feb 9 at 10:36
0

If you have other admin users you have no problems otherwise if you are not sure to avoid damage, before all create a new admin user via phpmyadmin. Login in wp-admin with the new credentials and modify or delete the old admin

Not the answer you're looking for? Browse other questions tagged or ask your own question.