3

In my footer, I have a set of links labeled Meta, it has...

Register
Log in
Entries RSS
Comments RSS
Wordpress.org

How can I remove just the wordpress.org and and comments rss link from the meta links?

6 Answers 6

6

Depending on your theme, they may be hard coded into a sidebar or footer file. If this is the case, you will need to get your hands dirty and edit your theme files.

But you can usually remove them by adding a widget, as these items often only show up when no widgets have been added. So go to Appearance -> Widgets and add the widgets that you want in the appropriate sidebar.

1
  • I found a solution, I copied the Meta Widget class code and made a new widget that doesn't have those items.
    – JasonDavis
    Jan 8, 2012 at 13:23
11

There's a super easy way to remove the wordpress.org link from the Meta widget. Just use:

add_filter( 'widget_meta_poweredby', '__return_empty_string' );

and it's gone!

2

I believe those are not generated by the system so you'd have to remove it by editing the theme. If your sure it's in the footer, edit the theme's footer.php by deleting those lines where those links are. In most themes, they are usually in sidebar.php, so if you don't find the links in footer.php, check for sidebar.php.

2
  • I copied the widget class and made a new class with a different widget name that has those items I don't want removed, and it is saved in my personal library code so it will not get overwritten if I update wordpress
    – JasonDavis
    Jan 8, 2012 at 13:25
  • Good you got it solved :)
    – Asko
    Jan 8, 2012 at 13:28
2

Use custom CSS...

.widget_meta > ul > li:nth-last-child(1) {
     display: none; 
}

.widget_meta > ul > li:nth-last-child(2) {
     display: none; 
}

Look here

1
  • Appearance => Customize -> Additional CSS ... add his CSS ... Publish. Done. Thanks. Mar 21, 2019 at 19:47
0

The answer by Oscar Silván is actually to remove the RSS links. To remove the WordPress link use:

.widget_meta > ul > li:nth-last-child(0) {
     display: none; 
} 

The numbers work backwards from the end. I have been trying to solve this problem for a couple of days now, and the answers given in the WordPress forum don't work.

Using the plugins suggested to stop the RSS feeds from working, but the links are still displayed. Since WordPress is now being used for static websites and not just blogs it is time they offered this in customization. Anyway it works fine for me now, and I only have the sign-on link for the administrators. I still have "powered by WordPress" at the bottom, but that is fine.

-1

If you have ever enabled the Meta widget you see a link to WordPress. I know many of us do not want this link to be there. There is a very simple way to remove it.

Find a file named default-widgets.php located in /wp-includes folder. Open default-widgets.php and remove the line 299:

<li><a href="http://wordpress.org/" title="<?php echo esc_attr(__('Powered by WordPress, state-of-the-art semantic personal publishing platform.')); ?>">WordPress.org</a></li>

to get rid of the link. However, with the upgrade you get this link back again and if you want to remove it, you need to follow the same procedure.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.