5

I have been working on my site through MAMP and with a localhost. I have not uploaded my site online yet.

I have worked in it for weeks accessing through the MAMP start page and then typing http://localhost:8888 on my browser.

Well, after a long night I woke up the next day and tried to log in as always. When I do it, my site appears on the browser but I cannot edit a thing. I mean, there is no way I can enter the admin panel, there are no tabs, no WP icon, not even the little EDIT squares at the end of every post or page where I clicked and it took me to the admin panel and dashboard.

I can navigate through the site, it works perfectly, It looks as if it was online, but simply I cannot edit anything.

I tried to remember what I did differently from the other days, and the only thing I came up with is that I updated a galleria plugin and I activated a new contact plugin widget. As I read in the forums I took all the plugins from my wp-content folder inside the WordPress folder but that did not solve the problem. I tried replacing the entire WordPress folder for a fresh download, the site looks funny no photos but still cannot access to the admin panel. I have no code or programming experience and am I new to WordPress. I am stuck with a dead line and no idea on what to do!

3
  • No need to shout...
    – Scott
    Commented Jan 5, 2012 at 15:23
  • Sorry I did not realize I did.I apologize! Commented Jan 5, 2012 at 15:32
  • Try using localhost/wp-login.php not just localhost/wp-login. I have the same problem but am not sure why its happening either until I figure it out this was my solution.
    – frog
    Commented Apr 1, 2013 at 7:36

4 Answers 4

3

The way you describe it, it sounds as if WordPress was installed to your root directory. That however doesn't explain why http://localhost:8888/wp-admin/ doesn't work, unless you renamed the directory..? Try accessing http://localhost:8888/wp-login.php

1
  • THANKS but it comes back as: The requested URL /wp-login.php was not found on this server. Commented Jan 5, 2012 at 19:19
1

Have you tried to log in using the following url once logged in?

http://localhost:8888/wp-admin

The reason your photos don't appear anymore is that they are not in the new install you've made. I hope that you did not erased the first install, because your medias are stored inside the wordpress/wp-content/uploads directory.

5
  • Thanks I have never logged in using a url I have always done it through the MAMP start page and then typing localhost:8888 on my browser. I have already st the photos back, that is not the proble. The issue is I don know how to access the admin panel Commented Jan 5, 2012 at 15:25
  • Used your suggestion and got" Commented Jan 5, 2012 at 15:26
  • used your suggestion and got: The requested URL /wp-admin was not found on this server. Commented Jan 5, 2012 at 15:27
  • 3.3.1 the latest Commented Jan 5, 2012 at 19:13
  • If you did not change the default theme, and if you are indeed logged in, you should see a column on the right of the home page, with "Archives" and "Meta" headers. Normally, there should be a "Site Admin" link. Click on that link and you will get to the dashboard. If this doesn't work, then you have a problem with your install. It is not normal (not default behaviour) that you cannot access the wp-admin directory. Commented Jan 6, 2012 at 9:48
1

it's a long shot but i think you forgot to type the folder name of you wordpress installation...

Are you sure you access your website directly on http:/localhost:8888/ ? because that means you installed your website on your local Sites folder root. If you access the website on http://localhost:8888/foldername/ than you should be able to access the wordpress admin on http://localhost:8888/foldername/wp-admin

3
  • 1
    It comes back as: Commented Jan 5, 2012 at 19:18
  • it comes back as: The requested URL /foldername/wp-admin was not found on this server. Commented Jan 5, 2012 at 19:19
  • DEAR TALBATZ when I login that way I do see my site working as if it were online, but I cannot edit anything, I cannot see the login tab or WP icon or the dashboard :( Commented Jan 5, 2012 at 19:23
1

I don't know if this going to help much, but try the command line and find wp-admin then type that location into the browser.

Not the answer you're looking for? Browse other questions tagged or ask your own question.