0

I've searched quite a bit and every single article seems to suggest the same thing, which I've tried to no avail.

I've already tried installing php7.4-gd. it did not fix the issue.

I tried adding this snippet to my functions.php file:

add_filter('wp_image_editors', 'wpse303391_change_graphic_editor');
function wpse303391_change_graphic_editor($array)
{
    return array('WP_Image_Editor_GD', 'WP_Image_Editor_Imagick');
}

Neither of these have fixed my issue.

I'm running XAMPP on debian. I imagine it has something to do with permissions because it's linux and 99% of all linux issues end up being permissions.

I got php 7.4.13

2
  • can you add screenshot? Dec 15 '20 at 16:56
  • Can you check the server error log to see if there's any more information there? Please also check the body of the AJAX response you're getting in your browser's network tab to see if there's any extra information there that the block editor code isn't displaying.
    – Rup
    Dec 15 '20 at 17:57
0
  • In some cases, the ImageMagick extension might not be installed or might be unreliable (old versions of ImageMagick can be buggy). If its okay then check the rest of points.

  • It's the GD Library not installed.If its installed you forget to restart server.

    sudo apt-get install php7.0-gd

Use this to stop Apache for it to make changes.

 sudo apachectl stop

Start Apache now and everything is fixed

. sudo apachectl start

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.