0

We have all comment notifications being emailed into our ticketing system (Freshdesk) and it's getting a bit muddy because of the redundant notifications.

What is currently happening:

  1. A site visitor makes a comment that is held for approval and an email is sent to us: "A new comment on the post "X" is waiting for your approval" = GOOD
  2. When the comment is approved by an admin, another email is sent to us: "New comment on your post "X"" = BAD
  3. When an administrator replies to a comment, another email is sent to us: "New comment on your post "X"" = BAD

In our Wordpress Discussion Settings, under the "Email me whenever" subsection, we have both "anyone posts a comment" and "a comment is held for moderation" checked. Under the "Before a comment appears" subsection, we have "comment must be manually approved" checked.

What settings do I need to change to turn off the emails in 2 and 3 above?

1

After some experimentation with the settings, I got it working as I wanted it to. Under Wordpress Discussion Settings, under the "Email me whenever" subsection, uncheck "anyone posts a comment".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.