I'm having font problems, or maybe character encoding on wordpress.

I am building a Thai website, most of the articles are in the correct language and there is no problem.

But there are a number of articles posted when posting errors in the article letters.

Such as:

https://prnt.sc/vswh8j or https://prnt.sc/vswi15

enter image description here

As in the picture I have given, some of the first characters can be Thai, but the following characters are like: "ี่๠€ ภ£ ๠‡ วà¸" and I don't translate get it in any language.

I don't think my source code supports Thai or something like that. I have tried researching on this problem a lot and tried many ways but to no avail.

Hope you can guide me to fix it. Thank you very much

  • Do the characters display ok in the backend/post editor after saving and reopening the editor? Or is this happening both back and frontend? If you copy the text into a WordProcessor do you get the broken characters or the original? What is the character encoding setting on your database tables? And are you using a 3rd party font provider such as google fonts? Edit your question to include these details, even if the answer is I don't know
    – Tom J Nowell
    Nov 30, 2020 at 15:23

2 Answers 2


It has many cases:

  1. check the character encoding in wp-config.php.

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
  2. check database character encoding

  3. check if the font you use supporting Thai letters

  • changing the character encoding in wp-config.php won't change the encoding of the database. It also needs to be multibyte utf8 or various language characters get truncated, e.g. emoji or japanese
    – Tom J Nowell
    Nov 30, 2020 at 15:14
  • You're right, i meant checking it with database not changing it. but in Arabic language sometimes it works by changing it with same database character encoding. Nov 30, 2020 at 16:05

I was having the same issue in my thai font website. Took one whole day to find out that I haven't added the meta charset="UTF-8" in the head section.

Adding UTF-8 solved the issue. Hope you might get some idea on how to solve it on wordpress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.