0

Wordpress still uses jQuery 1.x for fear of wrong compatibility with plugins and themes. They are trying to update it, but you can see that it will take a while yet (sources: one, two, three)

Now I am building a WP template where I have to use latest Bootstrap CSS framework. The problem is that Bootstrap uses the latest jQuery 3.5.1 !

So, will the latest Bootstrap work properly with the default Wordpress jQuery?

Note: I understand that I can register the latest jQuery and unregister the old ones, but this is not recommended as other plugins may use the default WP jQuery

0

Yes - it works fine with BS4 - no conflicts, no issues.

Simple way to test is to install a vanilla WP 5.3.3, create a barebones theme with BS 4 and check the JS console for issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.