0

uploading a picture on localhost I keep receiving following error:

Post-processing of the image failed likely because the server is busy or does not have enough resources. stopping any upload, even the file is relatively small, few kb, 1290x720, or max 1980x1020 or similar.

tried the way to modify app/theme/theme_name/app/setup.php by adding

add_filter( ‘wp_image_editors’, function() { return array( ‘WP_Image_Editor_GD’ ); } );

with no success. still having same issue.

created a plugin with:

add_filter( 'big_image_size_threshold', '__return_false' );

but still nothing (MEDIA settings are capped to 9999 per each dimension)

any basic config am I missing?

ty and best! :smiley:

EDIT: PS: no way with the “official” plugin as well… https://wpackagist.org/search?q=BIG+Image&type=any&search=

1
  • 1
    The message isn't saying you can't upload big images, it's saying you uploaded a large image and the server stopped responding when the image was uploaded. It isn't a configuration problem or a settings problem. Check your PHP error log, it's likely your computer was too slow and it couldn't resize the images in the allotted time, or it ran out of memory. It could even be a fatal PHP error in an unrelated piece of code, the PHP error log will give you the actual error – Tom J Nowell Nov 16 '20 at 16:31
0

the issue was connected to a standard too strict php.ini configuration.

to solve this, one has to update php.ini file setting to an higher

upload_max_file_size = 2M // something more

value.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.