0

I cannot see the media I have uploaded under the Media Library--it's a blank space(though I can upload with the html uploader ).

I cannot use the Select All checkbox to select all the plugins on the Plugins page. (I have to do them one at a time)

I cannot set a page or post to Draft.

In short, if it needs javascript, it doesn't work.

I have disabled ALL the plugins AND used a default theme (at the same time).

I have tried to install a few security plugins, but they all seem to use javascript. I have however run a few online scans and no malware turns up.

I was editing some images the day before, and it was working fine.

I don't know what else to do besides build the site back up from scratch.

I am running PHP 7.3.24 Wordpress 5.5.3 (the latest I believe)

Any ideas?

Edited to add that I have entirely replaced the wp-includes and the wp-admin folders. Also note that the site otherwise seems to work perfectly

1
  • 2
    Check the Developer Tools - Network tab, Console. Are there any errors or something unusual? Commented Nov 10, 2020 at 23:46

1 Answer 1

0

This is more likely that you updated to or beyond WordPress 5.5.

With the update to WordPress 5.5, a migration tool known as jquery-migrate will no longer be enabled by default. This may lead to unexpected behaviors in some themes or plugins who run older code.

This tool was removed in 5.5 and it's breaking many sites. Look for a plugin called jquery migrate helper. I'm betting that this will fix your problem.

As a note, this is a TEMP fix for the problem. This plugin will provide more information to solve the issue but it will not solve the main issue.

Your other option is to downgrade to an older version of WordPress temporarily on the live site and then address the issue on a staging site by updating your themes / plugins.

8
  • Enable jQuery Migrate Helper does not appear to have worked. Additionally I am not getting any jQ errors in the console tab or developer tools (all status 200). I will try to downgrade to an earlier version of WP unless anybody can think of something else.
    – user847288
    Commented Nov 11, 2020 at 19:24
  • before you do that, try disabling all plugins and changing themes...
    – rudtek
    Commented Nov 11, 2020 at 21:26
  • That was the first thing i did. The problem seems to be with this distribution of WP. I'll downgrade if I don't find another answer. Thanks for your assistance
    – user847288
    Commented Nov 12, 2020 at 1:30
  • what is the site address?
    – rudtek
    Commented Nov 12, 2020 at 23:09
  • The Javascript problem is only in the back end, for some reason. The site address is autofireguard.com
    – user847288
    Commented Nov 13, 2020 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.