1

I used to have a rss comment feed at the url /comments/feed which doesn't work anymore.

I checked the feed on feedvalidator and I've an error

line 111, column 29: Undefined named entity: ndash [help]

The line in question is comment where the content is

<guid isPermaLink="false">http://mart-e.be/?p=1694#comment-9711</guid>
<description>Ou mettre des &ndash; à la place des -
Mais oui la solution de rcommande fonctionne bien :)</description>

In the context, it is normal that there was an &ndash; there (explaining to write -- with &ndash;&ndash;).

Any idea how to fix this feed error ?

2
  • /comments/feed/still works on 3.3. Please provide more information for us to be able to investigate further. As it stands now the only way this can be answered is if someone has had the exact same problem and managed to solve it.
    – Scott
    Commented Jan 3, 2012 at 12:37
  • Ok actually the feed is working but invalid. I've updated the post content. Commented Jan 3, 2012 at 12:57

1 Answer 1

1

This issue may be the same over here: http://core.trac.wordpress.org/ticket/17767

Its currently submitted as a bug and hasn't been fixed yet. You can give the supplied attachment a go to see if it fixes the issue for you.

<description>Ou mettre des &ndash; à la place des -
Mais oui la solution de rcommande fonctionne bien :)</description>
        <content:encoded><![CDATA[<p>Ou mettre des &amp;ndash; à la place des -<br />
Mais oui la solution de rcommande fonctionne bien <img src='http://mart-e.be/wp-includes/images/smilies/icon_smile.gif' alt=':)' class='wp-smiley' /> </p>
]]></content:encoded>

You can see in your feed that the &ndash; is properly encoded in content but not the description.

Quick fix is to delete the comment with the &ndash; in it.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.