0

tl;dr: Two super users in a blog network. 15 sites. When second user logs-in block editor is gone. I can see Gutenberg > Demo menu item, I can open "Welcome to Gutenberg Editor" demo page, but this page (as well as all other pages and posts in all 15 sites in entire blog network) is rendered using regular code editor. For first user everything works as expected.


Overview

I have a blog network with 15 sites. I am using Gutenberg editor for editing my posts on every of these sites. I have Gutenberg plugin installed separately. Auto-updates enabled. Now version 9.3.0.

I also have two users in my blog network and they are both Super Users:

enter image description here

But the second one is actually inactive, used once per year or less. I post most of my posts via first user.

Gutenberg is installed, network activated and available on each site without any problems:

enter image description here

Problem

When I login as first user (admin, the one that I use the most) then everything is OK:

enter image description here

When I login with second user, on each and every site Gutenberg is simply… gone:

enter image description here

Details

As you can see in linked images, when I am logged-in as second user, I can still see that plugin is enabled and available, I can still see “Gutenberg” option in my side bar, I can still even click Gutenberg -> Demo, but when I click it… there’s no Guteberg at all. The same for all posts and pages and for each and every site.

Tested on PC, under newest version of Chrome and Edge under Windows 10 and on mobile phone under newest version of Chrome available for Android 8.0 Oreo. Tested on each and every of 15 pages that are part of my blog network. Everywhere exactly the same effects. All is working fine and dandy for the first user + Gutenberg is completely gone for the second user.

For a short period of time I have enabled SCRIPT_DEBUG mode as instructed here and here, but DevTools console under Microsoft Edge showed nothing alerting:

  • A suggestion to download the React DevTools for a better development experience
  • An intervention that images are loaded lazily and replaced with placeholders and load events are deferred
  • An error that WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed due to 403 response
  • A DOM warning that 2 elements are found with non-unique id #_wpnonce
  • And a Mixed Content warning that page at ‘/wp-admin/post-new.php?gutenberg-demo’ was loaded over HTTPS, but requested an insecure favicon so this request has been blocked, as the content must be served over HTTPS

So… nothing unusual, if I am not mistaken.

Conclusion

This is as weird as it can be and I am completely lost on where to even start looking for any source of this issue or any solution or workaround for it. Please, help, if you can.

0

As you can see in question, a lot of things were checked and a lot of debugging was performed, but the most elemental thing was not checked. The user in question had simply visual editor disabled in user configuration:

enter image description here

After enabling this issue become solved.

This is dumb and underlines my ignorance. The only explanation I have is that this particular user was created eight years ago and so was its options set.

I decided to keep this question open, so it can benefit others that may run into similar troubles in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.