We have post titles that contain emojis. While creating a post and saving it as a draft, the URL slug generated by WordPress doesn't add the [emoji] from the title. However, when the post is published, WordPress add the [emoji] from the post title into the posts' URL slug.

Is there any way I can disable WordPress from changing the URL slug when a post is published? Or any way to disable emoji support in URLs?

1 Answer 1


You're leaving WordPress to set your page slugs automatically.

Here's what's happening:

  1. When you save a Draft, WordPress will assign a "temporary" slug based on the post title.
  2. Once you complete your post, you'll then click Publish.
  3. WordPress will then rebuild your post slug based on the latest title since it was never explicitly set by you.

To fix your problem do this:

  1. Give your post a temporary title (that is different to your final title) and save it as a draft.
  2. Complete your posts along with emoji.
  3. Save Draft.
  4. Before Publishing your post, go to the Document settings and under the Permalink section, edit your slug so that it is now reflecting your desired post slug.
  5. Publish post.

See image. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.