0

I run WordPress on IIS10 on Windows Server 2016. When I try to login the page simply refreshes without any logged errors (not on screen, developer console or WordPress logs).

When I try the WordPress lost password screen (wp-login.php?action=lostpassword) and enter my username or email address I get:

ERROR: Enter a username or email address.

I tried everything as suggested here:

To summarize what I tried:

  • Renamed folder 'plugins' to 'plugins_backup'
  • Ran UPDATE wp_options SET option_value = 'a:0:{}' WHERE option_name = 'active_plugins';
  • added lines to wp-config for define('WP_HOME','https://www.example.com'); define('WP_SITEURL','https://www.example.com');
  • template is reset to "twentyseventeen"
  • deleted cookies
  • set WP_DEBUG and 'WP_DEBUG_LOG' to true in wp-config, though still no errors show when trying to login and also no logfile is created in wp-content folder.
  • [wp_usermeta] wp_capabilities field for my user has value a:1:{s:13:"administrator";b:1;}, so I'm an admin
  • Repaired all MySQL database tables via mysqlcheck -r [database]
  • In [wp_options] I then updated fields siteurl and home from my existing url (https://www.example.com/wordpress) to a random web address: "www.whatever.com". After login I'm now redirected to this address. So it almost seems the login IS succesful, but somehow it cannot load.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.