I am setting up a multiblog. In sub-blogs that mapped on a different domain, permalinks work with only "default" values. They broke if set to other valid values.

My main domain name is abc.com
I have three subdomains: aaa.abc.com, bbb.abc.com, ccc.abc.com
Everything works fine. Now, I need to map bbb.com to bbb.abc.com (for example). I've tried two methods: using the MU domain mapping plugin, and following the instructions there. In both cases, I get the exact same behavior:

  • Everything seems to work.
  • Domains are correctly setup and map correctly
  • Links on blogs work if set to "default" (p=123)
  • Permalinks on non-mapped sites (ccc.abc.com) work
  • on domains that are mapped (bbb.com) permalinks break if set to anything but default (yyyy/mm/post_name).

I've read countless threads, tried to modify my htaccess one thousand times, both trying the old markup, the new one, and several custom ones I found on different posts.
I've tried one million different custom permalinks (I'm pretty sure any kind permalink will not work).

this is my configuration for this domain name (the relevant part at least):

<VirtualHost *:80>
    ServerAdmin root@localhost
    ServerName abc.com
    ServerAlias *.abc.com
    ServerAlias *.def.com
    ServerAlias *.ccc.com
    ServerAlias *.bbb.com
    ServerAlias *.ghi.com

    DirectoryIndex index.html index.htm index.php
    DocumentRoot /my_root/

    RewriteCond %{HTTP_HOST} ^www.abc.com$ [NC]
    RewriteRule ^(.*)$ http://abc.com/ [R=permanent,L]

    <Directory /my_root>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            Allow from all

What can I do?


2 Answers 2


I think it;s the AllowOverride All - may need to fiddle with it. I've seen times where "all" didn't quite work as well as you'd think. Weird, but there ya go.


When you mapped the domain onto your multisite installation on the server, was it to the same root directory as your main WP install, or directly onto the subdomain? (I hope that makes sense).

Also, default permalinks as in /y/m/d/post or as in ?p=postnum?

  • All my domains are just wildcard mapped to my root wordpress install, if this is what you are asking. I'll update my question
    – Xananax
    Dec 29, 2011 at 8:38
  • What happens if you set the permalinks through network admin > sites > site options? Dec 29, 2011 at 12:07
  • The same. But anyway I've come to the conclusion that this isn't a wordpress problem, because I replaced index.php by one of my own that just diplays the server url that was given, and I get the exact same problem. Consequently, I've posted the question in serverfault: serverfault.com/questions/344978/… I keep the question open here though for people that might have the same problem in wordpress specifically.
    – Xananax
    Dec 29, 2011 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.