0

I was able to set a custom post type as the homepage for a woocommerce site I am building.

The problem is that when I do this, the homepage url does not display. (i.e. https://mywebsite.com).

Instead it displays as (https://mywebsite.com/post-type/post-name).

Using filters I was able to get rid of the post slug, but the name is still now present when set to the homepage. If I go to (https://mywebsite.com) the url bar displays (https://mywebsite.com/post-name).

Does anyone know how I can get rid of post-name in the URL when setting this as the homepage?

2
0

Sounds like you either need to set your index.php to display your hooks for that post type. Or you need to change your home page setup in the customizer. Here is a link on how to do that.

https://wordpress.com/support/pages/front-page/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.