0

It seems as though all WordPress sites that I’m supporting for various clients has this same functionality — if the site is using a static homepage, and you visit the homepage with a query string containing + signs — the page is redirected (301) and the plus signs are turned into %20 — Interior pages and posts do NOT suffer this same effect.

For example (I am not supporting this site, just using it as an example):

https://wpengine.com/?test=test+test (redirect occurs)

https://wpengine.com/plans/?test=test+test (no redirect occurs)

Another example:

https://wordpress.org/support/?test=test+test (redirect occurs)

https://wordpress.org/support/article/overview-of-wordpress/?test=test+test (no redirect)

Our site analyst (SEO, tracking, etc) uses plus signs in his data and this can be problematic. It seems that the homepage should NOT be doing this.

Is there a way to override this functionality, or is this a bug in WordPress?

This also does not seem affect sites that don’t use the “static homepage” option.

  • When you say a static homepage, do you mean you chose a page as your homepage in the settings? Or do you mean you created a home.php template in your theme? Or do you mean you have a static 1 page HTML site with an index.html for /? – Tom J Nowell Aug 25 at 16:41
  • Static homepage option is set in the settings. I'm fairly certain after more research this is a bug and I've submitted it to the Wordpress core.trac. – kevindeleon Aug 25 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.