0

So I've got the dreaded error too it seems. Apparently it's a very common issue but I can't really seem to get a hang on the fix.

One of the plugins my theme uses is causing the error as per the log I got in the email WordPress sent to my admin email. Here's the full log

Error Details
=============
An error of type E_ERROR was caused in line 8 of the file /home/younited/domains/younitedsupport.com/public_html/wp-content/plugins/rb-essentials/metaboxes/rb_metaboxes.php. Error message: Uncaught Error: Call to undefined function rb_get_metabox() in /home/younited/domains/younitedsupport.com/public_html/wp-content/plugins/rb-essentials/metaboxes/rb_metaboxes.php:8
Stack trace:
#0 /home/younited/domains/younitedsupport.com/public_html/wp-content/plugins/rb-essentials/metaboxes/metaboxes_exec.php(200): rb_setup_metaboxes()
#1 /home/younited/domains/younitedsupport.com/public_html/wp-includes/class-wp-hook.php(289): rb_save_metaboxes(4585)
#2 /home/younited/domains/younitedsupport.com/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
#3 /home/younited/domains/younitedsupport.com/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
#4 /home/younited/domains/younitedsupport.com/public_html/wp-includes/post.php(4260): do_action('save_post', 4585, Object(WP_Post), false)
#5 /home/younited/domains/younitedsupport.com/public_html/wp-admin/includes/post.php(687): wp_insert_post(Array)
#6 /home/younited/domains/younitedsupport.com/public_html/wp-admin/incl

Here's some additional information:
WordPress version 5.5
Current theme: Setech | Shared by WPTry.org (version 1.0.2)
Current plugin: RB Essentials (version 1.0.1)
PHP version 7.3.19

The website was running fine until yesterday on the exact same configuration. I made no changes that caused this error.

As you can guess, I have absolutely zero ideas what this means. I've tried disabling the plugin and reloading the site but it didn't work. Also, if I try to change the theme I get an HTTP 500 Internal Server Error(File "/home/younited/domains/younitedsupport.com/public_html/wp-admin/themes.php" is writeable by group) when clicking on the themes pages in WordPress.

The same site on my localhost works just fine BTW. Everything is identical between the two sites. Any ideas on how to fix this?

5
  • Your error states that it doesn't like line 8 of a particular file in the rb-essentials plugin. I'm not sure anyone here would say anything other than to contact the plugin developer... but... if you were to upload some of the code from that file there may be a more obvious issue. So can I suggest, find line 8 in the plugin file mentioned in the first line of the error and add to your original question not just that line but the function it sits within (e.g. above and below it if relevant). No need to upload the whole thing. Though in theory if you deactivate that plugin, the error should go? – t2pe Aug 20 '20 at 8:59
  • I tried deactivating the plugin but it didn't do anything. Also, the plugin is a theme essential so disabling it would basically break the theme I guess. – YaddyVirus Aug 20 '20 at 9:03
  • If the theme depends on the plugin then yes I guess it would cause a secondary error, though the error text should in theory be different. I'd still upload the function in line 8 to your question though. If folks here see the code they may have an idea. – t2pe Aug 20 '20 at 9:05
  • It'll take me a little while. Will do – YaddyVirus Aug 20 '20 at 9:12
  • Instead of deactivating the plugin try rename the rb-essential plugin directory. – Behemoth Aug 20 '20 at 14:41
1

So I reinstalled WordPress on both my live and local environments and downgraded to version 5.4.2 and everything seems to be working just fine, so far.

I'll update if anything breaks again.

0

I don't think this is an answer as such but I need a bit more space than the comment box allows...

Your line here:

"Also, if I try to change the theme I get an HTTP 500 Internal Server Error(File "/home/younited/domains/younitedsupport.com/public_html/wp-admin/themes.php" is writeable by group) when clicking on the themes pages in WordPress."

Suggests that the secondary error is complaining about file/folder permissions (ie. "is writeable by group").

If the file permissions were wrong it could potentially...

  1. Explain why your dev environment is ok when the live environment isn't
  2. Prevent some files being loaded which would then in turn lead to undefined function errors (and others)

If you've not changed the file permissions and this has happened suddenly, I would at least check that the site is healthy using one of the well-known security plugins. You could also check if there was a difference in the permissions via cPanel, or even the command line if you have access.

It's just a thought - that line about 'writable by group' is a warning flag of sorts.

5
  • I don't have a cPanel per se. The site is hosted on some sort of weird IP hosting given to me by my client. I do have FTP access though, so I guess I could check file permissions. What do you suggest they should be? Also, what do you mean by 'healthy'? Is there a possibility of malware on the site? Any plugin suggestions for that as well? – YaddyVirus Aug 20 '20 at 9:27
  • 1
    The two most well known WP security plugins are Wordfence and Sucuri. Make sure you don't run them at the same time but you can use both to check - I can't recommend one over the other and their are others. By healthy I just mean that it would pass a scan by either of those and at the very least it would rule out one potential cause. Permissions wise, have a look at the Support page on this as its pretty detailed but the advice varies according to hosting: wordpress.org/support/article/changing-file-permissions – t2pe Aug 20 '20 at 9:35
  • None of those things work. Note that this is a paid theme that I've downloaded from somewhere else for free. Could the theme developer be doing something to take down the website? – YaddyVirus Aug 21 '20 at 0:24
  • I guess its possible but unlikely in an off the cuff way. If the theme is a paid theme it may be that an update (or lack of) has created a problem for you. Some paid themes need license codes to update properly. The error you're seeing simply means that function isn't anywhere in the code. Unless there is a hosting issue (permissions, modification, file moved/deleted) the other reason is it might not exist in your version. I think at this stage its probably better to try and engage the developer, even if there is a cost attached because I think the alternative is to pay someone to take a look? – t2pe Aug 21 '20 at 9:18
  • Downgrading my WordPress version fixed the issue for now. I searched through the code and the function is there so I really don't know what caused the error. It's working fine for now – YaddyVirus Aug 23 '20 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.